Special-use domain name

A special-use domain name is a domain name that is defined and reserved in the hierarchy of the Domain Name System of the Internet for special purposes. The designation of a reserved special-use domain is authorized by the Internet Engineering Task Force (IETF) and executed, maintained, and published by the Internet Assigned Numbers Authority (IANA).[1]

Reserved domain names

The following list comprises the domain names list by IANA in the category of special-use domain names.[2]

DomainPurposeAuthority document
.altPreventing name collisions with DNSRFC 9476[3]
6tisch.arpaIETF 6TiSCH working groupRFC 9031[4]
10.in-addr.arpaReverse zones for IPv4 private networks (see AS112)RFC 6761[1]
16.172.in-addr.arpa
17.172.in-addr.arpa
18.172.in-addr.arpa
19.172.in-addr.arpa
20.172.in-addr.arpa
21.172.in-addr.arpa
22.172.in-addr.arpa
23.172.in-addr.arpa
24.172.in-addr.arpa
25.172.in-addr.arpa
26.172.in-addr.arpa
27.172.in-addr.arpa
28.172.in-addr.arpa
29.172.in-addr.arpa
30.172.in-addr.arpa
31.172.in-addr.arpa
168.192.in-addr.arpa
170.0.0.192.in-addr.arpaNAT64 prefix discovery[5]RFC 8880[6]
171.0.0.192.in-addr.arpa
ipv4only.arpa
254.169.in-addr.arpaReverse zone for the IPv4 link-local address space[7]RFC 6762[8]
8.e.f.ip6.arpaReverse zones for the IPv6 link-local address space[9]
9.e.f.ip6.arpa
a.e.f.ip6.arpa
b.e.f.ip6.arpa
.eap.arpaExtensible Authentication ProtocolRFC 9965[10]
.eap-noob.arpa
.home.arpaNon-unique use in residential networksRFC 8375[11]
.resolver.arpaFacilitate upgrading to encrypted DNSRFC 9462[12]
.service.arpaDNS-based service discoveryRFC 9665[13]
.exampleDocumentation, tutorials, or testing[14]RFC 6761[1]
example.com
example.net
example.org
.invalid
.test
.localUsed in multicast DNS (mDNS)RFC 6762[8]: §3 
.localhostRefers to the loopback addresses (:: and 127.0.0.1)RFC 6761[1]
.onionTor network onion servicesRFC 7686[15]

See also

References

  1. 1 2 3 4 S. Cheshire; M. Krochmal (February 2013). Special-Use Domain Names. Internet Engineering Task Force. doi:10.17487/RFC6761. ISSN 2070-1721. RFC 6761. Proposed Standard. Updates RFC 1918 and 2606.
  2. ↑ "Special-Use Domain Names". Internet Assigned Number Authority. Retrieved 2026-07-12.
  3. ↑ W. Kumari; MP. Hoffman (September 2023). The .alt Special-Use Top-Level Domain. Internet Engineering Task Force. doi:10.17487/RFC9476. ISSN 2070-1721. RFC 9476. Proposed Standard.
  4. ↑ J. Simon; K. Pister; M. Richardson (May 2021). M. Vučinić (ed.). Constrained Join Protocol (CoJP) for 6TiSCH. Internet Engineering Task Force. doi:10.17487/RFC9031. ISSN 2070-1721. RFC 9031. Proposed Standard.
  5. ↑ T. Savolainen; J. Korhonen; D. Wing (November 2013). Discovery of the IPv6 Prefix Used for IPv6 Address Synthesis. Internet Engineering Task Force. doi:10.17487/RFC7050. ISSN 2070-1721. RFC 7050. Proposed Standard. Updated by RFC 8880.
  6. ↑ S. Cheshire; D. Schinazi (August 2020). Special Use Domain Name 'ipv4only.arpa'. Internet Engineering Task Force. doi:10.17487/RFC8880. ISSN 2070-1721. RFC 8880. Proposed Standard. Updates RFC 7788.
  7. ↑ S. Cheshire; B. Aboba; E. Guttman (May 2005). Dynamic Configuration of IPv4 Link-Local Addresses. Network Working Group. doi:10.17487/RFC3927. RFC 3927. Proposed Standard.
  8. 1 2 S. Cheshire; M. Krochmal (February 2013). Multicast DNS. Internet Engineering Task Force. doi:10.17487/RFC6762. ISSN 2070-1721. RFC 6762. Proposed Standard.
  9. ↑ R. Hinden; S. Deering (February 2006). IP Version 6 Addressing Architecture. Network Working Group. doi:10.17487/RFC4291. RFC 4291. Draft Standard. Obsoletes RFC 3513. Updated by RFC 5952, 6052, 7136, 7346, 7371 and 8064.
  10. ↑ A. DeKok (May 2026). The eap.arpa. Domain and Extensible Authentication Protocol (EAP) Provisioning. Internet Engineering Task Force (IETF). doi:10.17487/RFC9965. RFC 9965. Proposed Standard. Updates RFC 5216, 9140 and 9190.
  11. ↑ P. Pfister; T. Lemon (May 2018). Special-Use Domain 'home.arpa.'. Internet Engineering Task Force. doi:10.17487/RFC8375. ISSN 2070-1721. RFC 8375. Proposed Standard. Updates RFC 7788.
  12. ↑ T. Pauly; E. Kinnear; C. A. Wood; P. McManus; T. Jensen (November 2023). Discovery of Designated Resolvers. Internet Engineering Task Force. doi:10.17487/RFC9462. ISSN 2070-1721. RFC 9462. Proposed Standard.
  13. ↑ T. Lemon; S. Cheshire (June 2025). Service Registration Protocol for DNS-Based Service Discovery. Internet Engineering Task Force. doi:10.17487/RFC9665. RFC 9665. Proposed Standard.
  14. ↑ D. Eastlake; A. Panitz (June 1999). Reserved Top Level DNS Names. Network Working Group. doi:10.17487/RFC2606. BCP 32. RFC 2606. Best Current Practice 32. Updated by RFC 6761.
  15. ↑ J. Appelbaum; A. Muffett (October 2015). The ".onion" Special-Use Domain Name. Internet Engineering Task Force. doi:10.17487/RFC7686. ISSN 2070-1721. RFC 7686. Proposed Standard.